Resolving COM Port issues 

AnyTone 868  878  878Plus


If you are experiencing connectivity issues with your radio, there are a few things we can try. First of all, you will want to go into Windows Device Manager with the radio plugged into your PC.  In Device manager, you should be able to see the USB connection under which the radio is plugged in, and if you click on that connection, Device Manager should also show you which COM port that connection is currently using.  If you cannot find your radio's connection in Device Manager, try unplugging the radio while Device Manager is showing.  The list should reset itself when you unplug the radio.  Look for any differences in the listing.  Now, when you plug your radio back into the PC, Device Manager should update again with the connection for the radio.  Click on that connection, and search the tabs for the COM port information as it should be there.


Also, please keep in mind that if you did not install your CPS software in administrator mode, you will need to uninstall CPS and then re-install it in administrator mode.


If you are experiencing com port issues, please consider trying the following:

Please also make note that Windows 10 will automatically detect your radio, so you will not need to install any additional drivers if you are using Windows 10. The additional driver available on our website is for use with Windows 7 only! If you have installed additional drivers in Windows 10, you'll either need to back up all of your data and reset Windows or you'll need to use a different PC (as installing the driver in WIndows 10 actually makes it impossible for the computer to detect your radio).

If you do need the COM port drivers, they are located here:

https://cdn.shopify.com/s/files/1/0833/9095/files/GD_32_64.zip?3484

The CPS programming software typically reads the radio when the correct COM port is selected. Please see the video guide in the link below:

https://www.youtube.com/watch?v=JR-TLtr4Mzc&t=184s

Other procedures that have been known to work in this instance include the following:

1. Leave the CPS open and the radio connected to the programming cable and the radio on. Unplug the USB side of the cable and plug it back in. Try this 3 times.

If not fixed

2. With CPS open and radio connected and on. Go into Device Manager in Windows and go to the Com Port for the radio. Go to update driver and select update from drivers on my computer. If there are more than one driver showing try it (or them if more)

3. With CPS open and radio connected and on.  Go into Device Manager in Windows and go to the Com Port for the radio. Delete the com port driver and/or uninstall.  Unplug the USB side of the cable and see if Windows reinstalls a good version of the driver.